Log in

View Full Version : Ubuntu

2007-03-10, 22:33

Linux had in the past a geek status which prevented it from being accepted by the mainstream. There are a number of reasons. One reason is that a greedy company such as Microsoft wanted to dominate the computer market. It used its wealth to promote and make deals so that new computers contained Windows installed already, and hardware devices would only work with Windows. Microsoft created momentum and inertia to make its operating system popular.

But regardless of that factor Linux was difficult to use due to its complexity to operate and the usage of more command line interfaces than graphical user interfaces. The advantage was therefore towards Windows. On top of that, the geeks wanted Linux to remain obscure to keep their exclusive club and clique off limits from the masses.

Visionaries came along and decided to try to bring Linux to the masses. The first project to do so was Lindows, which was an attempt to make an easy and popular acceptance of Linux. But Lindows failed to overthrow Windows or to gain popular acceptance. One of the problems was that Lindows was proprietary, and combined with its obscurity as a Linux variation, did not have much appeal. I tested out Lindows back in 2004, but I did not find it good enough to replace Windows with. You can read a review and comments on Lindows here:

I would say that the second attempt to bring Linux to the masses is Ubuntu, which has become even more popular than Lindows was. And it has remained non proprietary for regular users.

Deep pockets, a benevolent outlook, and stable commitment have made Ubuntu what it is. All of that came from Mark Shuttleworth and his company Canonical.

Ubuntu comes in the variations of: Ubuntu (Gnome desktop), Kubuntu (KDE desktop), Xubuntu (Xfce desktop, lighter on resources), Edubuntu (Ubuntu that is kid oriented). When a release occurs it is simultaneously released across all four lines. Each release has a nickname they give it. The most recent version 6.10 released in October was called "Edgy Eft". The forthcoming version 7.04, to be released in April, is named "Feisty".


I gave a try to installing Ubuntu 6.10 (Edgy) on a Compaq Presario 5365 that originally was made in 1999. The modified computer had a 450 mhz processor, a 20 GB master & 30 GB slave hard drive, and 316 MB of PC100 memory. Ubuntu is a type of Linux distribution. It refers to the drives in the computer system in the order they appear. For example; primary master drive is hda, primary slave drive is hdb, secondary master is hdc, secondary slave is hdd.

Before installing Ubuntu I erased the hard drives of the computer using a bootable CD that simultaneously wrote zeroes to the hard drives of both primary and slave drives. DiskZapper (http://www.3-3-3.org/forum/showthread.php?t=799) was the program that produced a bootable CD I used to erase the hard drives. With zeroes written to the hard drives, they were at first unusable and needed to be partitioned and mounted.

After burning both the standard Ubuntu desktop version (ubuntu-6.10-desktop-i386.iso) and the alternate version (ubuntu-6.10-alternate-i386.iso) to disc, I found that the standard version wouldn't install but the alternate version did install. I'm not sure why the standard one didn't, but it could be because the Compaq was old. I selected the default "Install in text mode" from the menu of the alternate install disc.

The menu of the CD has an ability to check the CD for errors. And on two different computers, both of the CDs I had burned from the iso files showed errors. Yet the MD5 hash of the downloaded iso versions that gave birth to the burned CDs, had the correct hash sum according to MD5summer (http://www.md5summer.org/). So either the self-checking feature of the Ubuntu CDs was wrong, or the CD burner was not making good copies. Since I was eventually able to successfully install Ubuntu, I figure that the feature in the CD menu to check the CD for errors was not working right.


When installing Ubuntu, it at first prompts you first for a hostname, which becomes the name of the root or console. By default it is "ubuntu". I named it "ubuntu-compaq". Later on it asks you for your real name, which you can leave blank. And then it prompts you for a username and a password, which are mandatory. I chose "eclectica" as the username.

Throughout the installation, most of the defaults should be chosen. You can use your tab key to move around and to go back. In the partition section I selected to partition the particular hard drive which was the primary master on the computer, rather than to manually edit the partition tables. I did not have any other operating systems on the computer. I selected /dev/hda, and then the default partition method rather than using LVM partitioning. When partioning the hard drive it will have the default answer of NO for the question "Write the changes to discs?". One would have to change the answer to YES to successfully partition the disc.

After the few questions in the beginning such as: language, keyboard, computer name, partitioning, time zone, username & password; it leaves you alone for a stretch of time while it installs the base Linux system. Then at some point the installation asks you the resolution settings of the X server, which I selected to be the default. Then you can leave it alone to finish its installation. It took my computer about three hours total time to install. A while after it was finished, I found the CD tray had opened by itself.

In my experimentation with Ubuntu, I reinstalled Ubuntu a few times after having caused fatal errors to the operating system which I didn't bother trying to figure out how to fix. Some of the times in the process of reinstalling it showed that there were errors, so I simply started over from the very beginning by rebooting the computer and selecting to Install in text mode from the CD menu. For me the place where errors always occurred was when it was installing the base Linux system, during when it said "select and install software", but never after it asked for the settings of the X server. So once it asked me for those X server settings, that meant to me the installation would be a success.

I don't know why the installations were so inconsistent, with there being problems installing at some times, and at other times having none, even when following the same procedures. Sometimes when installing it wouldn't ask me for the X server resolution settings, yet it still installed okay. The only thing I could think of causing an inconsistency was the behavior of the CD reader, or perhaps there were errors in the CD itself.


After logging in for the first time you will see on the top left the equivalent of what is the Windows Start button; with Applications, Places, and System. Also there on the top left is the Firefox browser, Evolution email, and Ubuntu help. On the top right is an indicator if any software updates are available or if a restart is needed, the volume control, the clock, and the log off button which can be confused with the close program button of Windows. I found that 131 updates totalling 207 MB were available. I don't know how many updates there would be if one were to install a zero day release. Version 6.10 was released four months prior to my installation. Perhaps some of the extra updates were there due to limitations of what could be fit on the installation CD.

After installation and updates, 2.2 GB of space on the hard drive was used.

I was surprised that Evolution email was installed instead of Mozilla Thunderbird, which I use on Windows. I read up on the subject and found that Evolution email integrates better with the Gnome desktop that comes with Ubuntu.

You can use the file browser to explore the files on your computer. Some of them are off limits to you unless you were to log in with username "root". Also many of the files and folders are hidden, so whether you see them or not depends on whether you have selected in your preferences to view hidden files. The creation of your username also created on the computer a home folder with the exact same username. On the computer for me, my home directory was /home/eclectica. The home directory is found in Places-->Home Folder. When I opened it at first there seemed to be little there, until I selected to view the hidden files.


After I got Ubuntu up and running I thought I would be able to easily format and partition the other hard drive, as you can in Windows, but I didn't see such an option anywhere. One has to go into the terminal window to do so. To get into the terminal window, go to Accessories-->Applications-->Terminal. That brings you to the equivalent of the Command MS DOS prompt in Windows.

For your information on terminal window commands, the term "sudo" is necessary at the beginning of most commands, because it gives you the superuser root status necessary to perform the command. No sudo, no cando.

In the terminal window you can see what is going on with the hard drives attached to your computer by typing sudo fdisk -l. It will at that point prompt your for your password. It showed both hard drives for me, and told me:
Disk /dev/hdb doesn't contain a valid partition table

I tried at first to partition the second hard drive in the terminal window, using the command sudo fdisk /dev/hdb, but was unsuccessful to get whatever I did to it to afterwards mount in the system. So I decided instead to use the Ubuntu installation CD to partition the CD for me. I booted into the CD and selected to Install in text mode. I immediately tabbed to the "go back" button hoping to get to the main menu, but at that point it was not the full main menu of the installation CD. So I had to enter my language, location, and keyboard setup. Then when it asked me for the hostname of the computer I tabbed a couple of times to the "go back" button to get the full installation menu, which became available at that point. From there I selected to "partition disks", and that time selected to partition disc /dev/hdb. When that was finished I selected "go back" to the main installation menu, and I aborted the installation.

Once the hard drive in question is already partitioned, there are some steps to permanently mounting it so that it is recognized by the operating system. These steps need to be typed in the terminal window. In the example below, the hard drive to mount is designated as "hdb1", as determined by the command sudo fdisk -l.

1. sudo mkdir /media/hdb
2. sudo gedit /etc/fstab
this will open up the fstab file. You will then add the following line on the bottom and save. You can hit your tab where there is a space so that it looks okay to you in the text file.
3. /dev/hdb1 /media/hdb ext3 rw,user 0 0

If you had Windows XP on that slave drive in question, you would not have partitioned it, but only needed to mount it. You would follow the same procedures but for the editing of the fstab file you would have added instead:
/dev/hdb1 /media/hdb ntfs rw,user 0 0

After that, I restarted and I had a new icon on the desktop named "hdb". I also saw it in Places-->Computer. The master hard drive was listed as "Floppy 1" and the floppy drive was listed as "Floppy". I could not write or use the new hdb drive though because it was only usable by the system administrator account "root".

In order to make the hard drive usable for the regular users such as yourself rather than just for root, you will have to log in as "root" yourself to change the permissions of the hard drive. By default in Ubuntu you can not log in at the beginning using the account "root". But you can change that in the Ubuntu menu System-->Administration-->Login Window-->Security and selecting "Allow local system administrator login". Then restart the computer, and you can log in as username "root".

When logged in as username "root", right-click on the properties of the other hard drive in the Ubuntu menu item Places-->Computer. There in the Permissions tab you will see three sections: Owner, Group, and Others. For "Folder access" select to "Create and delete files" for all three groups. Then you can again restart the computer and log back in with your regular username. You should be able to read, write and delete files and folders from the second hard drive without having to log in as "root".


On my Windows computer I use the screen resolution of 800 by 600. Using a PS/2 KVM+audio switch, the Ubuntu computer looks best to me at 1024 by 768. I noticed that changing the resolution in Ubuntu didn't change the font size in web pages, but only the image sizes. So I ended up at first setting the font size to be increased 1 notch with Firefox in Ubuntu, whereas I had it on the normal font size with Firefox in Windows. But the problem with that solution was that whenever Firefox was restarted, it went back to the regular font size. Finally I decided the best solution was going into the Firefox preferences, under Content-->Fonts & Preferences, and changing the default font size from 16 to 17, and being satisfied with that. (In Ubuntu the Firefox options are under Edit-->Preferences, whereas in Windows they are under Tools-->Options.) I also went to the Advanced settings and changed the monospace size from 12 to 13. I noticed too that in Windows a specific font was selectable in that Firefox section, whereas in Ubuntu it was a general choice of either Serif or Sans Serif. For Proportional fonts it was selected by default to be Serif in Ubuntu. I changed it to be Sans Serif and it looked clearer and better.


I had a printer attached to a networked Windows XP computer which I selected already in Windows to be shared. In Ubuntu I wanted to use that same printer. I went in to the menu of Ubuntu under System-->Administration-->Printing and selected to Add Printer. Then it loaded the printer database, which took some time. Afterwards Step 1 of 3 asked me printer type, which I chose to be Network Printer. From the drop down menu I then chose Windows Printer (SMB). I was then able to find the actual Windows machine by its name under Host, and then identify the Printer attached to it. It also asked me for the workgroup username and password, but they can be left blank if you set it that way in the Windows sharing settings. In step 2 of 3 I also had to specify the printer make and model of the printer attached to the Windows machine, to which it gave me a suggested driver. So apparently it bypasses the Windows drivers when printing and uses its own Linux drivers. Step 3 of 3 for adding the printer was putting in the printer information, where you can name it whatever you want. Finally I selected the newly added printer to be the default printer from the main printer menu.


I hooked up a USB Canon CanoScan LiDE70 scanner to the computer and nothing happened. It was supposed to launch the XSane image scanner automatically when the scanner was plugged in. I then manually launched the program and it told me that no devices were available. I found out that some companies don't provide drivers for Linux. The Canon scanner I have works for Windows or Mac, because drivers were provided for it on the accompanying CD. Since Linux is open source, it is the easiest of operating systems to create interoperable software for. Therefore the absence of provided Linux drivers is not really due to obscurity of Linux or difficulty for Canon. Rather, the cause is conspiracy and collusion on the part of Microsoft, Apple, and Canon to give people an incentive to keep using proprietary systems.

The two companies which make products that are most Linux friendly are: Epson and Brother.


You can add or remove software installed on your computer in System-->Administration-->Synaptic Package Manager. By hitting "reload" you get the latest listings from Ubuntu Central there. You can see what is installed already, and you can search. They are organized with different sections by software type. It showed at first that there were 4764 packages listed, with 1072 of them already installed.

When I tried to play an mp3 file after the new installation of Ubuntu, the file was associated with the Totem movie player. But the program couldn't open it. I thought it was pretty pathetic with a new installation of an operating system in 2007, that I couldn't even play an mp3. But perhaps this was done purposely, in light of the fact that mp3 is a patented format that is not free the way ogg is. Microsoft recently was ordered to pay 1.5 billion dollars to Bell Labs for usage of the mp3. So perhaps the people at Ubuntu do not package such things out of fear of liability. But then when I couldn't play an avi file either, I realized that Totem is just a worthless piece of shit and that's probably all there was to it.

I decided I wanted to install a working mp3 player using the Synaptic Package Manager. In the Multimedia section I found one named xmms. When I selected XMMS I was informed that it would also need to install 4 other pieces of software such as libgtk, which it selected for me. To install all 5 pieces of software, I then hit the Apply button, and it downloaded and installed all of them.

A more user friendly place to add and remove programs is in the menu item Applications-->Add/Remove Software. You can search there for things. I noticed that a search there for "amule" showed four results, whereas in the Synaptic Package Manager, nothing came up. It seems that the search is broken or difficult to use in the Synaptic Package Manager, though there is actually a larger selection there. Later on after reloading Synaptic Package Manager, it showed 20,224 packages listed there rather than the initial 4764.

One problem I had with searching in the Add/Remove Applications section was that it instantly searches as soon as you start typing. So as I typed out the word "amule" it started searching first for "a", then for "am", then for "amu". That would ordinarily give you faster search results, but on a computer with a slow processor such as I have, it ended up getting bogged down by doing so many unnecessary searches, that I couldn't even see what I was typing in the search window. The search results gave me 4 results, and I selected to install aMule (not aMule GUI). Afterwards I was informed that a shortcut for aMule was placed in Applications-->Internet.


You can find your local IP address by typing ifconfig in the terminal window. You can get system information, and the amount of resources used by the applications by going to System-->System Administration-->System Monitor. I found a good program to monitor the processor and memory of the computer that displays like a widget. It is GKrellM and can be added in the Add/Remove Applications section. After observing it run I found that the reason the computer is slow for me is due to it having a slow processor, causing a long time for programs to open.


I like to transfer files between the computers on the LAN using ftp servers. To retrieve files from the Windows computer running an ftp server, I installed ftp client gFTP. By default it has FTP-->Options-->Preserve file permissions checked, and I had to uncheck that option in order to download files onto the Ubuntu computer from the Windows computer. It's a decent enough program to use.

To send files back to the Windows computer, I wanted to use an ftp server. But I didn't find a decent FTP server program to use. I installed vsftpd, but afterwards when I clicked to run it nothing happened.


After the installation of XMMS, and later on after the installation of VLC media player, I found that mp3 files were still opening with the Totem movie player when I clicked on them. But I noticed now a shortcut for the newly installed XMMS player in Applications-->Sound & Video. So I then right-clicked on an mp3 file for its properties. I went to the Open With tab, and the +Add button, to select XMMS from the list of programs. Then I selected XMMS. Afterwards when double-clicking on the mp3 it opened with XMMS and I was able to play the mp3.

I tried inserting an audio CD to the computer to see what would happen. It was recognized and an icon was created for it on the desktop. The Sound Juicer program opened up automatically. I right-clicked on the desktop icon to see the properties of the audio CD, but was unable to change the associated program with it. I found the controls for audio CDs to be located instead in System Preferences-->Removable Drives and Media-->Multimedia tab. There you can select the action to be taken when a CD is inserted into the computer. I wanted to change the default CD player to XMMS, and it gave me folders to browse for the location of the XMMS player. So I was wondering where to find it, and I finally figured out that it was in File System/usr/bin, where most applications are found. I clicked on that and it entered the command /usr/bin/xmms for me, which opened the program but did not play it after CD insertion. I then experimented and it also opened XMMS for me when I abbreviated it without the file path by typing for the Command xmms, but it's better just to use the full file path.

It would be an improvement for Ubuntu if they were to make it as easy to browse for an application here as they do when changing the application associated with a file extension. How many people know that the progams are located in File System/usr/bin? I changed it to "xmms %m" and found it both opened and played using XMMS when a CD was inserted. As another improvement for Ubuntu, the commands should be replaced with checkboxes explaining their functions, rather than people having to put things like %h or %m after the name of the application. Or there should be a guide or key there to explain what those commands mean. I also think it is mislabeled there to say "Play audio CD discs when inserted", because if %m is not added after the name of the application it will not play automatically. It should be labeled instead something like "open this program when audio CD is inserted".

For curiosity I experimented with another CD I have: Angie Stone - Stone Love. The reason I selected that particular one is because it contains malware that automatically loads onto the system of Windows computers, as you can read about in this previous thread:
copy protected CDs (http://www.3-3-3.org/forum/showthread.php?t=868)
I wanted to see what a malicious CD would do to a Linux computer which has auto insert notification enabled. When I inserted the CD in Ubuntu I received a notification that the CD contained both audio and data files. It gave me the choice to either play the CD or to browse the files. When I selected to play the CD, it launched XMMS without playing anything, and it had the last mp3 file I played loaded into the player rather than the CD itself. I was able to play the CD with the Sound Juicer program by clicking the CD icon on the desktop. I inserted the CD again and this time I selected to browse the files. Nothing happened when doing so and I was not able to browse the files in the computer's file browser either. I could only open up the audio files with the Sound Juicer program. I tried again with another enhanced CD that I have, which does not contain malicious software: King Crimson - Projekct Two - Space Groove. The same things happened there as with the Angie Stone CD.


The following filesharing programs come listed already in Ubuntu 6.10's Add/Remove programs section, and are therefore easy to install. I also list the networks they support.
aMule (http://www.amule.org/) ED2K, Kademlia
GTK-Gnutella (http://gtk-gnutella.sourceforge.net/) Gnutella
MLDonkey (http://mldonkey.sourceforge.net/) ED2K, Overnet
Nicotine (http://nicotine.thegraveyard.org) SoulSeek
xMule (http://www.xmule.ws/) ED2K

The following file distribution tools are also available for installation in that section:
Azureus: BT
BitTornado: BT
BitTorrent: BT
KTorrent (KDE): BT
Gnome PeerCast: PeerCast

I installed aMule and was pleased with how well it worked. But I do not like that when conducting a search, neither bitrate or length of song information is shown. Azureus, which also requires the installation of Sun Java Runtime, crashed without working. As of March 10, a new version of Azureus was installed with the latest updates I downloaded from Ubuntu. But the new version still crashed and closed a couple of minutes after launching.


So what if you want a piece of software that is not listed in the Add/Remove programs section? There are plenty of good programs out there which aren't listed. For example, FrostWire (http://www.frostwire.com) p2p. You need to find something which is Debian compatible, and then preferably compatible with Gnome or GTK. Not all Linux distributions are the same.

So I gave a shot at downloading FrostWire. I chose the Debian/Ubuntu version to download. Its filename was frostwire-4.13-1.5-1.i586.deb. When I double-clicked on the file it opened and installed automatically with GDebi package installer, which comes by default with Ubuntu. It then put a shortcut for FrostWire on Applications-->Internet. When I tried to open FrostWire, nothing happened. I found that I also needed to install Sun Java 5.0 Runtime, which was found in the Ubuntu list of Add/Remove Applications.

I think as long as you stick to programs made for Debian, ending with .deb you will be okay. For example, you will see on the Ethereal download page (http://www.ethereal.com/download.html) that the Linux version that is given prominence there is the one for Red Hat / Fedora with a file extension of rpm. And then below you can find the one for Debian under "Other Platforms". They had various ones there but the one that looked like it would work for Ubuntu for my computer was the one for i386 with a file name of ethereal_0.10.10-2sarge9_i386.deb. However when clicking on that download link at Debian.org, it gives a server error message. So one could then do an internet search for that exact same filename and should find it mirrored somewhere else.

I had the same problem at Debian.org when trying to download another program called tcptrack (http://www.rhythm.cx/~steve/devel/tcptrack/) with a filename of tcptrack_1.1.5-1_i386.deb. I found it on a mirrored site by searching for it. When I tried to install it I received a message from GDebi that a later version was available in a software channel. So I aborted the installation. Then I looked more carefully and realized that while the home page of tcptrack listed version 1.2.0-1 as being the latest stable version, Debian.org listed version 1.1.5-1 as stable and 1.2.0-1 as unstable. I then did a search for filename tcptrack_1.2.0-1_i386.deb and found a working downloadable mirror. This time when installing it I received a message from GDebi that an older version was available in the software channel. I installed regardless of the message. I found out later on that the Synaptic Package manager had version 1.1.5-2 already listed, and that's why I received the the older than / newer than messages from GDebi, because it recommends using primarily whatever version is already listed and available in the Synaptic Package manager.

Unlike the installation of FrostWire, after the installation of tcptrack I did not see a shortcut for it anywhere listed in the list of Applications. So I had to manually add it. To create a shortcut to your program, go into System-->Preferences-->Menu Layout. You can see that some applications are listed in italics there but are unchecked, such as Internet-->BitTorrent. That means they are already installed. I checked everything I could there, as I would prefer having access to all the programs. You can add a shortcut to your new program by clicking "New Item", or put it in its own category by selecting "New Menu". Then you can select to browse, which browses the /usr/bin folder by default, and you can select your program there, where once selected its path will be entered in the command line. It also asks you for a name and a comment for the application. So basically that operation is the same thing as adding a new program shortcut in the Start menu of Windows.

I ended up being unsatisfied with the tcptrack program because it wouldn't run, so I then uninstalled it. I first uninstalled it in the Synaptic Package Manager. I clicked on it there and had it set to "mark for complete removal". After its deletion I then went into System-->Preferences-->Menu Layout and right-clicked on it to delete the shortcut to it.

Another place to find stuff to install is from http://packages.ubuntulinux.org/. There you would search for "Edgy", or whatever version of Ubuntu you happen to be running.


The good thing about installing FrostWire was that it gave me access to the Gnutella filesharing network. Frostwire also opens torrent files, but I didn't test that feature. The port settings for FrostWire are found in Tools-->Options-->Advanced-->Firewall Config-->Listen on Port. I found that it had selected a random listening port, but I switched it back to the classic Gnutella port 6346. I also needed to change in that same section under "Router configuration", the selection to "Manual Port Forward", or it would keep generating random ports with the default and recommended "UPnP" selection. And I forwarded both TCP and UDP ports 6346 to the computer in my router.

Frostwire has a problem in that it does not share files which contain special foreign language characters such as , , . I found that 20 of my 983 files were not being shared as a result of that. I did a search for "Rokia" and found works by Rokia Traor that I was able to download. And upon downloading, I found that the song with special characters in its name was listed in my shared files. So it's a FrostWire problem, not a Gnutella problem. It's a bug which I hope they will fix soon.


I am pleased with Ubuntu and I believe that this is the one which will surpass Microsoft with performance and popularity. I look forward to the new release of Ubuntu 7.04 in April and will perhaps do a review of that here too.

I now have Ubuntu installed on my weaker computer and Windows XP on my powerful one. At some point that will probably switch, and my weaker computer will be running Windows while my powerful computer runs Ubuntu. Why should I waste a good computer by having it run Microsoft Windows?

I may also try running Xubuntu on the older computer, as it is said to work well on older computers because it doesn't use as many computer system resources. I think some of the problems I had with running Ubuntu were due to it running on a weak computer. I am currently in a state of ambivalence in that I don't want to have all Ubuntu computers at home yet. But it says a lot that in less than a month of time using Ubuntu, that I value it as much as I value Windows, which I've been using for 11 years.

Eventually I plan to migrate both of my computers to Ubuntu and its variations. The things which stop people from migrating to another operating system are: familiarity or investment with certain software that is particular to an operating system, and having hardware (such as my Canon scanner) which doesn't work on another operating system.

Windows has inertia and will still be around for years, as AOL continues to be. There will be no dramatic day of reckoning for it. The change will occur slowly, with individuals deciding one by one that they prefer Ubuntu to Windows.

Microsoft has a lot of momentum on its side, but the cracks are forming. At this time it has released an operating system "Vista" which is actually worse than its predecessor Windows XP. You can read about just one of the problems with Vista here:
A Cost Analysis of Windows Vista Content Protection (http://www.cs.auckland.ac.nz/~pgut001/pubs/vista_cost.html)

While Microsoft is going downhill, Ubuntu is going uphill and is set to surpass Microsoft in both quality and popularity.

There's no way I'm ever going to accept the shit that Microsoft expects me to eat, and to pay for on top of it. I will not accept Vista on any computer that I use. Windows Vista is the bad sequel which I've come to expect from Microsoft. Windows XP is the end of the line for running a Microsoft operating system on my computer.

2007-08-12, 19:04
Some things have changed in the last five months. I could no longer install anything on the old Compaq computer and sent it to the garbage. I think one of the problems with it was that the CD unit on it needed to be cleaned. That was also the reason that I got inconsistencies before in the attempted installation of Ubuntu. When trying to install Kubuntu, Ubuntu, and Xubuntu on another computer later on, I also had the same problem. But only Xubuntu and Ubuntu were helpful enough to tell me that there was an error reading the disc. Kubuntu simply quit in the middle of the installation. So thanks to the helpful information, it occured to me to get a CD unit cleaner, which is an audio CD with little brushes on it that I bought for $17.

After sending the Compaq to the trash, I got a new computer from Tiger Direct. I made sure to choose from the no operating systems category (http://www.tigerdirect.com/applications/category/category_slc.asp?Sort=4&Nav=|c:336|&Recs=30) so as not to give a single dime to Microsoft. I ended up getting for $350 from Systemax; a computer that has 512 MB of memory, 80 GB hard drive, DVD burner, 3.33 GHz processor. What I found interesting was the presence of the SATA hard drive; as all the hard drives I've seen in the past are (P)ATA or IDE. The motherboard on the new computer I bought supports both PATA and SATA connections for hard drives.

I installed Ubunu 7.04 on the new computer and made that my regular working computer. I was able to migrate my inbox and sent files from Mozilla Thunderbird on Windows XP into the Ubuntu computer. These large files were about 100 MB each. I copied them and overwrote the files named "inbox and "sent" that were there after the new installation of Thunderbird, into the Ubuntu computer at /home/username/.mozilla-thunderbird/xxxxxxxx.default/Mail/Local Folders. If you want to view that folder you have to make sure that you can view hidden files in your folder viewing preferences.

So I copied all my personal files over from the Windows computer, exported my address book from Thunderbird and my bookmarks from Firefox. Everything worked out okay. One thing I couldn't make use of in Unbuntu was .rar files. I unpacked them into their folders before copying them over from the Windows computer to the Ubuntu computer. In the future I will simply avoid downloading .rar files on filesharing networks. And another thing I no longer have a use for is the Canon scanner, which I can give away to some wretched Windows or Mac user.

About a month ago I discovered that my filesharing computer running Windows XP had some problems. Scanning the computer using Spybot (http://www.safer-networking.org/), I found that there were some programs on there that shouldn't be there. In the past I had done that and found nothing more than tracking cookies. So when I found these malicious programs, I realized that my days running a pirated copy of Windows XP were to be no more, because pirated copies of Windows XP can not use Windows Update and have many vulnerabilities. Just a little more than one year ago I turned off automatic updates because of Windows Genuine Advantage (http://www.3-3-3.org/forum/showthread.php?t=995). As a result it was only a matter of time that my computer would become vulnerable, because Windows has many vulnerabilities that people eventually find out about and write programs to try to exploit.

I copied all my personal files on the Windows computer by way of an ftp server BRS WebWeaver (http://www.brswebweaver.com/), using the LAN to transfer all the files to the Ubuntu computer. Then I erased the hard drive of the Windows computer. I noticed that file names which contain special characters such as , , ; were not copied properly from the Windows computer to the Ubuntu computer. Originally I blamed FrostWire for not sharing those files. But it appears that the problem comes with Ubuntu or Linux in how it handles those characters. Files with special characters copied from another Linux computer on the LAN did not have that problem in retaining those special characters. Nor did I have a problem with downloading a file having special characters in its name from a Linux server on the internet. So I think the problem was that the encoding behind the special characters is different between Windows and Linux. When a file is copied from one operating system to another, those special characters are lost. Therefore to avoid those problems, it is best that one rename one's files where there are special characters so that there are not problems. For example, should be changed to e, to o, and to n.

After erasing the hard drive I then tried to install the Ubuntu variants onto the computer.

Kubuntu: I installed this at first. It uses the KDE desktop. It has a nice look to it. I thought this would be a good complement to having Ubuntu on the other computer. It is most similar to Windows in its appearance with the panel by default on the bottom. In Ubuntu you are prompted for your administrative password to perform certain tasks. In Kubuntu, it does not prompt you but instead has a different mode, called administrative mode, that you have to be in to perform those tasks. So if you are not in administrative mode some options are faintly visible, indicating that you need to be in administrative mode to use them. It seemed to me that I had to enter my administrative password more often with Kubuntu than with Ubuntu, which was more inconvenient. In the end I did not like the feel of Kubuntu. Maybe it was the Konqueror browser that annoyed me about it, or that many of the programs started with the name K, or that it seemed too proprietary and reminded me of Windows.

Xubuntu: I tried this next. It is like Ubuntu but comes with just a few programs installed. For example only the word processor of Open Office was installed by default. One would probably not want to install this rather than Ubuntu, unless one has to because it is on a computer that has little space or small resources. Xubuntu can be thought of as Ubuntu Lite, but Ubuntu is preferable. Xubuntu comes with a screen saver by default that requires you to use your administrative password to unlock it.

Edubuntu: This one is very close to Ubuntu but comes with a different set of programs installed by default. The difference between Ubuntu and Edubuntu is really just that. And the other difference lies with appearance, using different icons, colors, and fonts. I ended up settling with Edubuntu on the second computer. By doing so it allowed me to easily distinguish one computer from the other, rather than having two Ubuntu computers, because of the difference in appearance.

To sum it up; Kubuntu is the least similar to Ubuntu, Xubuntu is Ubuntu Lite, and Edubuntu is Ubuntu with educational programs installed by default.

I was initially reluctant to install any program designed for KDE, on Ubuntu. There are many programs out there for KDE. But one can install them also on Ubuntu, and Ubuntu will simply add a KDE interface for those programs to work properly. It's just that it's not as efficient to use those KDE programs on a Gnome desktop as it is on a KDE desktop, because it requires for both desktops to run and it uses more system resources.

Here are some good KDE programs which I found to be worthwhile to install on Ubuntu.
* KSnapshot: This is a good program for capturing screen shots.
* KTorrent: a good BitTorrent protocol client. Azureus, which uses Java as its engine, continues to crash more often than Teddy Kennedy after a drinking binge, but regardless of that KTorrent is a better program. It is also lighter on resources than Azureus.
* KNetStats: I recommend this as a way to monitor your network traffic. When you start it by itself it should show two computer icons; one representing upload and the other download. If there is no network traffic then the icons should be blue. They turn to green when there is traffic. The problem I found was that when launching KNetStats, that it didn't display in the panel right away. And when I put it there, the upper right icon was green and the bottom left was blue regardless of network traffic. It appears that this is because KNetStats doesn't launch properly due to its being written for KDE, and the plugins for Gnome which Ubuntu has assigned to it are inadequate. I found a way to make it work properly, was to open and close another KDE program, KTorrent. The opening of KTorrent then loaded the correct KDE plugins, which allowed KNetStats to work properly. I reported it in Ubuntu as bug 131685 (https://bugs.launchpad.net/ubuntu/+source/edubuntu-meta/+bug/131685).

Folder Sharing and File Sharing

I had problems in Ubuntu version 6.10 of sending files to another computer on the LAN, because I couldn't get a decent FTP server working. That hasn't changed, but I've found other options so I can now easily move files from one computer to another. In System->Administration->Shared Folders you can set what folders are shared. You can have it set to share by way of SMB or by way of NFS, and I have mine set to the default SMB method. There I also set the access to be read only for security. Once that is set up, on the other computer in the network you would go to Places->Network and see the computer by its computer name there. When you copy files over from one computer to another, you will run into problems if the files that you are copying have permissions which restrict them from being read. If you are copying entire folders with many files from one computer to the other, you should verify that the copied folder and the original folder all have the same size and number of files in them. If you have displayed your permissions in the folder view under Edit->Preferences->List Columns, you should see the following permissions for the regular folders and files that you work with:

permissions: drwxr-xr-r
octal permissions: 1600755

permissions: -rw-r--r--
octal permissions: 600644

The last three numbers of the octal permissions may be familiar to those of you who have used ftp clients to connect to ftp servers. On websites the typical permission level of folders the public sees are 755, and 644 for the files. The three numbers represent in order: owner, group, others. And the actual numeric value displayed is the sum of: read=4 write=2, execute=1.

There seems to be another way for you to share files on computers in the LAN, but I couldn't get it to work. It is found in System->Preferences->File Sharing. It activates something on default port 10021, which I think is some kind of ftp server. I tried connecting to it on the other computer using FileZilla, but was unable to do get a directory listing.


When I installed aMule version 2.1.3 on Edubuntu, it came with a bad default server list. The server.met file is for connecting to ED2K, and the nodes.dat file is for connecting to Kademlia. Usually what people do when firing up the *Mule is to connect to the ED2K network, and then bootstrap to the Kademlia network by way of other clients on the ED2K network. Due to a bad server list, it started out not being able to connect at all to ED2K and not being able to get an updated server list. Hence I could not connect to Kademlia either. The invalid address in aMule was:
How I resolved that problem was by going into the Networks->ED2K tab and changing the address there. I changed it to:
Once I did that I was able to connect to ED2K, and other *Mule clients starting downloading from me. Finally after about five minutes I was able to bootstrap my way into the Kademlia network from those clients.

One thing to look out for in aMule is that the files and folders which you download will have restrictive permissions by default. The control for that in aMule is found in Preferences->Security->Default Permissions. By default it is set to 640 for files and 750 for directories. You should change that to 644 and 755.


FrostWire is a Gnutella network client written in Java. As of this writing I have version 4.13.2 installed on my Edubuntu filesharing computer. The program still does not come in the Ubuntu list of add/remove programs, but can be easily installed from FrostWire's website (http://www.frostwire.com/). In fact the download link for FrostWire from the website is geared towards whatever your computer machine reads to them, so if you visit the site from a Windows computer it will give you by default the download link for the .exe Windows version. Visiting the site on an Ubuntu computer, it will by default point you to the .deb version. This is what a server reads along with my IP address when I visit a site:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061201 Firefox/ (Ubuntu-feisty)
And that is how they know to give you the right download link by default.

Because of the Java, running FrostWire uses 55 MB or more of memory. In Tools->Options->Uploads->Upload Bandwidth I have set the upload limit to be 18 KB/second, which it respects. Some clients I've used in the past before are greedy and seem to surpass your set bandwidth limits. I've had that problem with Shareaza for Windows. The Monitor tab of FrostWire shows uploads on the bottom half, but the downloads are found not there on the top as would be expected, but in the Search tab instead. In a way that layout is more convenient because you can both see your search results and the progress of your downloads at the same time. On the top half of the Monitor tab, instead of downloads you can see the searching that goes on in the Gnutella network if you check the option. The program gave me a message saying that I was a leaf rather than a node in Gnutella, and that I wouldn't be able to see search results. But I was able to see many search results. FrostWire showed in the Monitor window about 9 KB/s of uploading, while I was showing 18 KB/s with KNetStats. After investigating that more, it appears that the speed that FrostWire indicates in your upload window is inaccurate, and is actually half or two thirds of what it really is.

The following programs supporting searchable filesharing networks are easily installed and available from Ubuntu 7.04 in the add/remove programs section. The list has grown since version 6.10:

aMule (ED2K, Kademlia)
dc_gui2 (Direct Connect)
dc-qt (Direct Connect)
giFToxic (OpenFT)
giFTui (OpenFT)
Gtk-Gnutella (Gnutella)
Lopster (OpenNap, SlavaNap)
Museeq (SoulSeek)
Musetup-GTK (SoulSeek)
Nicotine-Plus (SoulSeek)
valknut (Direct Connect)


Gedit is the default text editor that comes with Ubuntu. I am satisfied with it for most of my text editing jobs for files that stay in an electronic format. If I were printing something then I would want to use Open Office to prepare the document. One thing to watch out for in Gedit is that by default when you save a document, it creates a backup of the old one with a similar file name that is "hidden". So you may have some old documents lying around that can't be seen in your folder unless you've chosen to view "hidden" files. In the Gedit preferences under the Editor tab, the option there is checked on by default: create a backup copy of files before saving. If you have Gedit open already and you open a second document from your hard drive, it will show the second document also within Gedit in a tabbed fashion the way Firefox does with two websites. But it will then display that first document to you, not the one you just clicked on. That could cause problems for the user because one could confuse the documents with each other.

Something to make a note of in Linux versus Windows is that a file extension by itself will not change what program will open it. For example if I rename a file from .txt to .doc, it will not cause it to open with Open Office instead of with Gedit. That is because the system will still recognize it as a plain text document. And there is nowhere in a program's menu where you can hijack a program's extensions, because the operating system is sovereign over any program by default. For example, in the VLC of Windows menu I can set VLC to open all .avi files in Windows. In VLC of Linux I have to do it instead in the operating system. I would have to right-click on the .avi file, and then on its properties I would select the Open With tab.

gThumb Image Viewer

The default program for opening .gif files is Image Viewer. However it does not play animated gifs. If you select to open your .gif files instead with gThumb Viewer, they will be displayed properly.

playing A/V files

The player which I use to play audio files is Audacious. The player I use for video files is VLC media player. The default player for A/V files in Ubuntu is Totem, which still does not work.


A good amount of websites don't use the fonts that work with Linux. You can specify in Firefox the default font for a site. Some sites such as Wikipedia (http://en.wikipedia.org/) are written with no font specified, so that your default font of the browser can be used. And besides you can in Firefox's preferences, over rule any site's fonts. That would be in Edit->Preferences->Content->Advanced uncheck allow pages to choose their own fonts, instead of my selections above. Even with that unchecked, sites will still be able to choose other effects such as bold, italics, and font size. I found that my three favorite fonts in Ubuntu are: sans-serif, Dustismo, and Samanata. And a good size for them in the Firefox preferences on my 17 inch CRT 1024 by 768 monitor, is to have either sans-serif size 15, Dustismo size 18, or Samanata size 16. My problem though with Dustismo and Samanata is that it is hard to tell the difference between a period and a comma when proofreading, because they are so small.

You can also adjust the fonts in your computer by going to System->Preferences->Font. This is how I've set that:
Application font: Sans size 10
Document font: Sans size 10
Desktop font: Sans size 11
Window title font: Sans Bold size 10
Fixed width font: Sans size 11

Even how I've set my fonts there effects the font of Gedit, because I've set in my Gedit preferences to use the System fixed width font. In Firefox I can't seem to select Sans when looking to set a font in the preferences. There I see a lot of fonts with the name "sans" in them, but no Sans by itself. I think that sans-serif is the same font as what the system calls Sans.